DATAPOT

トップページ検索サイト構築:動作環境

検索サイト構築システム「Alamode」動作環境

「Alamode」パッケージ版を導入頂く場合、インストールするサーバに下記の環境が必要です。
条件を満たしたサーバで動作可能です。専用サーバ、自社サーバなどで下記ソフトウェアがインストールされていない場合は 弊社でインストール代行させて頂く事も出来ます(要root権限)。パッケージ版ご注文時にその旨お問い合わせ頂くか、サポートまでご連絡下さいませ。

言語 PHP 4.3〜5系
※低負荷・高速で動作するモジュール版のPHPを推奨します。
※セーフモード不可
※2010年4月現在のバージョンまで確認
データベース Alamode ver2.5:MySQL 3.23系〜4.0系
Alamode ver3.0:MySQL 4.1〜5.0系
※MySQL4.0系を推奨。innoDBが必要です。
※2010年4月現在のバージョンまで確認
Webサーバ Apache等
OS Linux・FreeBSD・Windows・Mac OS等

レンタル版では弊社サーバにインストールされますので、お客様側でサーバを準備する必要はございません。
パッケージ版が動作するサーバ導入に関してのご質問・ご相談などサポートまでお気軽にご相談下さいませ。

Alamode動作確認 共有ホスティングサーバ

PHP5系及びMySQL4.1系以降に対応したAlamode3.0の運用テストを、レンタルサーバ各社にて行っております。
2009年11月27日現在までの調査結果をまとめましたので、ご参考下さいませ。
※アクセス速度やディスク容量、設置出来るデータベースの数、アップロード制限、データ転送量制限等については自己責任でお願い致します。

ロリポップ PHP 5.2.8 CGI版 / MySQL 4.0.26・MySQL 5.1.34
MySQL5.1.34系の場合はphp.iniの設定でdefault_charsetをUTF-8に変更。
Pデラサーバー PHP 4.4.6 モジュール版
session.use_cookiesをOnからOffに変更
チカッパ PHP 5.2.6 CGI版 / MySQL 4.0.26・MySQL 5.0.51
ハッスルサーバー PHP 5.2.8 CGI版 / MySQL 4.0.27・MySQL 5.0.51
さくら(スタンダード) PHP 5.2.8 CGI版 / MySQL 5.1.33
MySQLの文字コードがEUC-JPなので、Alamode EUC-JP版インストールで動作。
エックスサーバー PHP 4.3.9 CGI版・PHP 5.1.6 CGI版 / MySQL 4.0.27・MySQL 5.0.22
CPI(シェアードプラン) PHP 4.4.7 CGI版・PHP 5.2.4 CGI版 / MySQL 4.0.27・MySQL 5.0.45
MySQLの文字コードがEUC-JPなので、Alamode EUC-JP版インストールで動作。
ヘテムル heteml PHP 5.2.5 モジュール版 / MySQL 5.0.82
php.iniの設定でdefault_charsetをUTF-8に変更。

※Alamodeを複数インストールしたり、中・大規模な検索サイト運営の場合は、仮想専用サーバまたは専用サーバを推奨致します。
※サーバによっては「CSVファイルのアップロード機能」でエラーが発生する事がありますが、データベースユーザにFILE権限が与えられていない事が原因です。 ソース修正で対応が可能ですので、CSVファイルのアップロードでエラーが発生した場合はサポートまでお問い合わせ下さい。